aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-10-08 18:58:24 +0200
committerMattias Andrée <maandree@operamail.com>2012-10-08 18:58:24 +0200
commite600c3cb471bb23792a959e885f504cd48757bb5 (patch)
tree1b9172f695c1850c55b43d01079d2f4dba43c584 /setup.py
parent21eb7358f2cacd339e3670cad080608524510a63 (diff)
downloadponysay-e600c3cb471bb23792a959e885f504cd48757bb5.tar.gz
ponysay-e600c3cb471bb23792a959e885f504cd48757bb5.tar.bz2
ponysay-e600c3cb471bb23792a959e885f504cd48757bb5.zip
m + ensure that change stuff always has proper permissions
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 5cbda4b..b3f2dca 100755
--- a/setup.py
+++ b/setup.py
@@ -505,9 +505,9 @@ class Setup():
print('Creating directory ' + dir)
os.mkdir(dir)
print('Setting permission mode mask for ' + dir + ' to 6777')
- Popen('chmod -R 6777 -- ' + dir, shell=True).wait()
+ Popen('chmod -R 6777 -- \'' + dir.replace('\'', '\'\\\'\'') + '\'', shell=True).wait()
print('Setting group for ' + dir + ' users')
- Popen('chown -R :users -- ' + dir, shell=True).wait()
+ Popen('chown -R :users -- \'' + dir.replace('\'', '\'\\\'\'') + '\'', shell=True).wait()
for shell in [item[0] for item in shells]:
if conf[shell] is not None:
for command in commands: