aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-10-08 18:30:32 +0200
committerMattias Andrée <maandree@operamail.com>2012-10-08 18:30:32 +0200
commit21eb7358f2cacd339e3670cad080608524510a63 (patch)
tree82afda797d5f801bb5196577c06fb794bd08b284 /setup.py
parent0560ae64728dbfe538d9b5edfb3690f3c1e60979 (diff)
downloadponysay-21eb7358f2cacd339e3670cad080608524510a63.tar.gz
ponysay-21eb7358f2cacd339e3670cad080608524510a63.tar.bz2
ponysay-21eb7358f2cacd339e3670cad080608524510a63.zip
chown -R :users for cache
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4298366..5cbda4b 100755
--- a/setup.py
+++ b/setup.py
@@ -506,6 +506,8 @@ class Setup():
os.mkdir(dir)
print('Setting permission mode mask for ' + dir + ' to 6777')
Popen('chmod -R 6777 -- ' + dir, shell=True).wait()
+ print('Setting group for ' + dir + ' users')
+ Popen('chown -R :users -- ' + dir, shell=True).wait()
for shell in [item[0] for item in shells]:
if conf[shell] is not None:
for command in commands: