aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-09-29 23:08:13 +0200
committerMattias Andrée <maandree@operamail.com>2012-09-29 23:08:13 +0200
commit8231dbe8f663e13297ddaab871d95e9e87575829 (patch)
tree4df72c514d413ab660fcba359a21c2a8a9ad18e3 /setup.py
parent04aae4a3aa354485be4b2a148ac2e2ed7bbf7208 (diff)
downloadponysay-8231dbe8f663e13297ddaab871d95e9e87575829.tar.gz
ponysay-8231dbe8f663e13297ddaab871d95e9e87575829.tar.bz2
ponysay-8231dbe8f663e13297ddaab871d95e9e87575829.zip
rename setup (foreward compatiblity) option --lib-dir to --libexec-dir and add proper --lib-dir
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 24bd570..b856379 100755
--- a/setup.py
+++ b/setup.py
@@ -210,9 +210,12 @@ class Setup():
opts.add_argumented (help = 'Set the system\'s directory for command executables\nDefault = $PREFIX/bin',
alternatives = ['--bin-dir'], arg='BINDIR')
- opts.add_argumented (help = 'Set the system\'s directory for non-command executables\nDefault = $PREFIX/lib/ponysay\nNot used.',
+ opts.add_argumented (help = 'Set the system\'s directory for non-executable libraries\nDefault = $PREFIX/lib/ponysay\nNot used.',
alternatives = ['--lib-dir'], arg='LIBDIR')
+ opts.add_argumented (help = 'Set the system\'s directory for non-command executables\nDefault = $PREFIX/libexec/ponysay\nNot used.',
+ alternatives = ['--libexec-dir'], arg='LIBDIR')
+
opts.add_argumented (help = 'Set the system\'s directory for resource files\nDefault = $PREFIX/share',
alternatives = ['--share-dir'], arg='SHAREDIR')
@@ -841,6 +844,7 @@ class Setup():
if opts['--opt'] is not None:
if opts['--bin-dir'] is None: opts['--bin-dir'] = ['/opt/ponysay/bin']
if opts['--lib-dir'] is None: opts['--lib-dir'] = ['/opt/ponysay/lib']
+ if opts['--libexec-dir'] is None: opts['--libexec-dir'] = ['/opt/ponysay/libexec']
if opts['--share-dir'] is None: opts['--share-dir'] = ['/usr/share']
if opts['--with-shared-cache'] is None: opts['--with-shared-cache'] = ['/var/opt/ponysay/cache']
for sharedir in sharedirs:
@@ -848,7 +852,7 @@ class Setup():
for sharefile in sharefiles:
conf[sharefile[0]] = '/opt/ponysay/share/' + sharefile[1]
- for dir in ['bin', 'lib', 'share']:
+ for dir in ['bin', 'lib', 'libexec', 'share']:
if opts['--' + dir + '-dir'] is not None:
d = opts['--' + dir + '-dir'][0]
if dir == 'lib':