aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-10-08 18:27:44 +0200
committerMattias Andrée <maandree@operamail.com>2012-10-08 18:27:44 +0200
commit0560ae64728dbfe538d9b5edfb3690f3c1e60979 (patch)
tree294208b4535c3c59b3d29382106f76ca6aeb6fa5 /setup.py
parentac94c903f607b29fbb1ec7074005a41e92a40b4b (diff)
downloadponysay-0560ae64728dbfe538d9b5edfb3690f3c1e60979.tar.gz
ponysay-0560ae64728dbfe538d9b5edfb3690f3c1e60979.tar.bz2
ponysay-0560ae64728dbfe538d9b5edfb3690f3c1e60979.zip
recursive chmod, safety first
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b5374c1..4298366 100755
--- a/setup.py
+++ b/setup.py
@@ -505,7 +505,7 @@ class Setup():
print('Creating directory ' + dir)
os.mkdir(dir)
print('Setting permission mode mask for ' + dir + ' to 6777')
- Popen('chmod 6777 -- ' + dir, shell=True).wait()
+ Popen('chmod -R 6777 -- ' + dir, shell=True).wait()
for shell in [item[0] for item in shells]:
if conf[shell] is not None:
for command in commands: