aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-10-08 18:26:30 +0200
committerMattias Andrée <maandree@operamail.com>2012-10-08 18:26:30 +0200
commitac94c903f607b29fbb1ec7074005a41e92a40b4b (patch)
treefcc73414e4d710b0d127bb301f1c3ab9a029cf71 /setup.py
parent5c736f63ae56b4a1ee464dd39e26315d3b95cfd1 (diff)
downloadponysay-ac94c903f607b29fbb1ec7074005a41e92a40b4b.tar.gz
ponysay-ac94c903f607b29fbb1ec7074005a41e92a40b4b.tar.bz2
ponysay-ac94c903f607b29fbb1ec7074005a41e92a40b4b.zip
python's chmod does not do anything
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 62ab9eb..b5374c1 100755
--- a/setup.py
+++ b/setup.py
@@ -502,8 +502,10 @@ class Setup():
if not os.path.exists(pdir):
print('Creating intermediate-level directories needed for ' + dir)
os.makedirs(pdir)
- print('Creating directory ' + dir + ' with mode mask 6777')
- os.mkdir(dir, 0o6777)
+ print('Creating directory ' + dir)
+ os.mkdir(dir)
+ print('Setting permission mode mask for ' + dir + ' to 6777')
+ Popen('chmod 6777 -- ' + dir, shell=True).wait()
for shell in [item[0] for item in shells]:
if conf[shell] is not None:
for command in commands: