summaryrefslogtreecommitdiff
path: root/DSP/Source/ComplexMathFunctions/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'DSP/Source/ComplexMathFunctions/CMakeLists.txt')
-rw-r--r--DSP/Source/ComplexMathFunctions/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/DSP/Source/ComplexMathFunctions/CMakeLists.txt b/DSP/Source/ComplexMathFunctions/CMakeLists.txt
new file mode 100644
index 0000000..16e06c6
--- /dev/null
+++ b/DSP/Source/ComplexMathFunctions/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required (VERSION 3.6)
+
+project(CMSISDSPComplexMath)
+
+
+file(GLOB SRC "./*_*.c")
+
+add_library(CMSISDSPComplexMath STATIC ${SRC})
+
+configdsp(CMSISDSPComplexMath ..)
+
+### Includes
+target_include_directories(CMSISDSPComplexMath PUBLIC "${DSP}/../../Include")
+
+
+