summaryrefslogtreecommitdiff
path: root/DSP/Source/CommonTables/CMakeLists.txt
diff options
context:
space:
mode:
authorrihab kouki <rihab.kouki@st.com>2020-07-28 11:24:49 +0100
committerrihab kouki <rihab.kouki@st.com>2020-07-28 11:24:49 +0100
commit96d6da4e252b06dcfdc041e7df23e86161c33007 (patch)
treea262f59bb1db7ec7819acae435f5049cbe5e2354 /DSP/Source/CommonTables/CMakeLists.txt
parent9f95ff5b6ba01db09552b84a0ab79607060a2666 (diff)
downloadst-cmsis-core-lowfat-master.tar.gz
st-cmsis-core-lowfat-master.tar.bz2
st-cmsis-core-lowfat-master.zip
Official ARM version: v5.6.0HEADmaster
Diffstat (limited to 'DSP/Source/CommonTables/CMakeLists.txt')
-rw-r--r--DSP/Source/CommonTables/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/DSP/Source/CommonTables/CMakeLists.txt b/DSP/Source/CommonTables/CMakeLists.txt
new file mode 100644
index 0000000..7bdad93
--- /dev/null
+++ b/DSP/Source/CommonTables/CMakeLists.txt
@@ -0,0 +1,31 @@
+cmake_minimum_required (VERSION 3.6)
+
+project(CMSISDSPCommon)
+
+
+
+add_library(CMSISDSPCommon STATIC arm_common_tables.c)
+
+if (CONFIGTABLE AND ALLFFT)
+ target_compile_definitions(CMSISDSPCommon PUBLIC ARM_ALL_FFT_TABLES)
+endif()
+
+if (CONFIGTABLE AND ALLFAST)
+ target_compile_definitions(CMSISDSPCommon PUBLIC ARM_ALL_FAST_TABLES)
+endif()
+
+include(fft)
+fft(CMSISDSPCommon)
+
+include(interpol)
+interpol(CMSISDSPCommon)
+
+target_sources(CMSISDSPCommon PRIVATE arm_const_structs.c)
+
+configdsp(CMSISDSPCommon ..)
+
+### Includes
+target_include_directories(CMSISDSPCommon PUBLIC "${DSP}/../../Include")
+
+
+