aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorjaseg <git@jaseg.net>2018-07-20 17:12:54 +0200
committerjaseg <git@jaseg.net>2018-07-20 17:12:54 +0200
commitf3bcb6c4c5c4fee81a5c8eccbe915e781872f57c (patch)
tree01a5e53f6d9998857c27c55ab4965594b4b9d470 /setup.py
downloadnyanping-f3bcb6c4c5c4fee81a5c8eccbe915e781872f57c.tar.gz
nyanping-f3bcb6c4c5c4fee81a5c8eccbe915e781872f57c.tar.bz2
nyanping-f3bcb6c4c5c4fee81a5c8eccbe915e781872f57c.zip
Initial commit
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..a762258
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,25 @@
+#!/usr/bin/env python3
+
+from setuptools import setup, find_packages
+setup(
+ name = 'nyanping',
+ version = '0.0.2',
+ py_modules = ['ping'],
+ scripts = ['nyanping'],
+ description = ('Improved graphical ping tool'),
+ url = 'https://github.com/jaseg/nyanping',
+ author = 'jaseg',
+ author_email = 'github@jaseg.net',
+ install_requires = ['python-mpv'],
+ license = 'GPLv3',
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: Manufacturing',
+ 'Intended Audience :: Science/Research',
+ 'Intended Audience :: Religion',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)',
+ 'Topic :: Utilities'
+ ]
+)