aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorjaseg <code@jaseg.net>2018-07-08 13:03:17 +0200
committerjaseg <code@jaseg.net>2018-07-08 13:03:17 +0200
commitc46df0a2a85b1d777f20927bbcb9612680b2fd38 (patch)
treec4173d67525679498e9bb7e03c26b255e659b46a /setup.py
parent66752c94b38400c7a7b4c4d3494204f808c459f4 (diff)
downloadgerbolyze-c46df0a2a85b1d777f20927bbcb9612680b2fd38.tar.gz
gerbolyze-c46df0a2a85b1d777f20927bbcb9612680b2fd38.tar.bz2
gerbolyze-c46df0a2a85b1d777f20927bbcb9612680b2fd38.zip
setup.py: Make README fit for PyPI
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 9 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 27c7d26..fa82b9d 100755
--- a/setup.py
+++ b/setup.py
@@ -1,14 +1,21 @@
#!/usr/bin/env python3
-from setuptools import setup, find_packages
+from setuptools import setup
+
+def readme():
+ with open('README.rst') as f:
+ return f.read()
+
setup(
name = 'gerbolyze',
- version = '0.1.0',
+ version = '0.1.6',
py_modules = ['gerbolyze'],
scripts = ['gerbolyze'],
description = ('A high-resolution image-to-PCB converter. Gerbolyze reads and vectorizes black-and-white raster '
'images, then plots the vectorized image into an existing gerber file while avoiding existing features such as '
'text or holes.'),
+ long_description=readme(),
+ long_description_content_type='text/x-rst',
url = 'https://github.com/jaseg/gerbolyze',
author = 'jaseg',
author_email = 'github@jaseg.net',