diff options
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -505,9 +505,9 @@ class Setup(): print('Creating directory ' + dir) os.mkdir(dir) print('Setting permission mode mask for ' + dir + ' to 6777') - Popen('chmod -R 6777 -- ' + dir, shell=True).wait() + Popen('chmod -R 6777 -- \'' + dir.replace('\'', '\'\\\'\'') + '\'', shell=True).wait() print('Setting group for ' + dir + ' users') - Popen('chown -R :users -- ' + dir, shell=True).wait() + Popen('chown -R :users -- \'' + dir.replace('\'', '\'\\\'\'') + '\'', shell=True).wait() for shell in [item[0] for item in shells]: if conf[shell] is not None: for command in commands: |