aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 8 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 7088f59..fc8d6d6 100755
--- a/setup.py
+++ b/setup.py
@@ -27,13 +27,14 @@ setup(name = 'ponysay',
author = 'jaseg',
author_email = 'ponysay@jaseg.net',
url = 'https://github.com/jaseg/ponysay',
- py_modules = ['ponysay'],
- data_files = [dir_copy('quotes', 'ponies'),
- dir_copy('genponies', 'ponies')],
- scripts = ['ponysay',
- 'ponythink',
- 'termcenter',
- 'ponysay-qotd'],
+ packages = ['ponysay'],
+ package_dir = {'ponysay': 'ponysay'},
+ package_data = {'ponysay': ['quotes/*.quotes', 'ponies/*.pony']},
+ entry_points = {'console_scripts': [
+ 'ponysay=ponysay:main',
+ 'ponythink=ponysay:main',
+ 'ponysay-qotd=ponysay:qotd_server',
+ 'termcenter=ponysay:termcenter']},
zip_safe = False,
classifiers = [
'Development Status :: 5 - Production/Stable',