aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-08-27 17:32:26 +0200
committerMattias Andrée <maandree@operamail.com>2012-08-27 17:32:26 +0200
commita3447540e1e3113416e613405cc95a6bc1dd13b2 (patch)
tree4f3550deb86830d2b5a9af1e03d92a5b6f0562b4 /setup.py
parent6fef59fc47beb30b4664bdb5e693e7e4ab4ffabe (diff)
downloadponysay-a3447540e1e3113416e613405cc95a6bc1dd13b2.tar.gz
ponysay-a3447540e1e3113416e613405cc95a6bc1dd13b2.tar.bz2
ponysay-a3447540e1e3113416e613405cc95a6bc1dd13b2.zip
make fix
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 14 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 891ee9c..1279238 100755
--- a/setup.py
+++ b/setup.py
@@ -64,6 +64,8 @@ class Setup():
opts.add_argumentless(alternatives = ['--help'])
opts.add_argumentless(alternatives = ['--version'])
+ opts.add_argumented (alternatives = ['---DESTDIR'], arg="DESTDIR")
+ opts.add_argumented (alternatives = ['---PREFIX'], arg="PREFIX")
opts.add_argumentless(help = 'Install everything that is not explicity excluded', alternatives = ['--everything', '--with-everything'])
opts.add_argumentless(help = 'Install only the essentials\nNote that this can vary depending on version', alternatives = ['--minimal'])
@@ -137,6 +139,17 @@ class Setup():
self.linking = opts.opts['--linking'][0]
+ if (opts.opts['---DESTDIR'] is not None) and (opts.opts['--dest-dir'] is not None):
+ destdir = opts.opts['---DESTDIR'][0]
+ if len(destdir) > 0:
+ opts.opts['--dest-dir'] = [destdir]
+
+ if (opts.opts['---PREFIX'] is not None) and (opts.opts['--prefix'] is not None):
+ prefix = opts.opts['---PREFIX'][0]
+ if len(prefix) > 0:
+ opts.opts['--prefix'] = [prefix]
+
+
if (len(opts.files) > 1) or (opts.opts['--help'] is not None) or ((len(opts.files) == 1) and (opts.files[0] == 'help')):
opts.help()
elif (opts.opts['--version'] is not None) or ((len(opts.files) == 1) and (opts.files[0] == 'version')):
@@ -784,7 +797,7 @@ class Setup():
destdir = opts['--dest-dir'][0]
for key in conf:
if conf[key] not in (None, False, True):
- if conf.startswith('/'):
+ if conf[key].startswith('/'):
conf[key] = destdir + conf[key]
return conf