aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-10-08 18:21:34 +0200
committerMattias Andrée <maandree@operamail.com>2012-10-08 18:21:34 +0200
commit4ea588f966d2911be4f4b1c3bb9be59c01d3cc2a (patch)
tree3758b39c7bd803a3eb05c6148bf14fd5b459d8a2 /setup.py
parentf838e1c8e955ee1f115cfc85cc29ff0f1eef8e4a (diff)
downloadponysay-4ea588f966d2911be4f4b1c3bb9be59c01d3cc2a.tar.gz
ponysay-4ea588f966d2911be4f4b1c3bb9be59c01d3cc2a.tar.bz2
ponysay-4ea588f966d2911be4f4b1c3bb9be59c01d3cc2a.zip
Change cache directory permissions to 0o6777 from 0o0777
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index b856379..62ab9eb 100755
--- a/setup.py
+++ b/setup.py
@@ -8,7 +8,7 @@ from subprocess import Popen, PIPE
-PONYSAY_VERSION = '2.7'
+PONYSAY_VERSION = '2.8'
@@ -502,8 +502,8 @@ class Setup():
if not os.path.exists(pdir):
print('Creating intermediate-level directories needed for ' + dir)
os.makedirs(pdir)
- print('Creating directory ' + dir + ' with mode mask 777')
- os.mkdir(dir, 0o777)
+ print('Creating directory ' + dir + ' with mode mask 6777')
+ os.mkdir(dir, 0o6777)
for shell in [item[0] for item in shells]:
if conf[shell] is not None:
for command in commands: