aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-08-25 21:56:29 +0200
committerMattias Andrée <maandree@operamail.com>2012-08-25 21:56:29 +0200
commit1f409609b57dd86693371a4bedfe3a1e8ebba3e8 (patch)
treed85f2f7f2cd4f0630d3f85799352eac8d4f34e48 /setup.py
parente946668e06cad2ed1b3f7168319ba592e7d5cdb7 (diff)
downloadponysay-1f409609b57dd86693371a4bedfe3a1e8ebba3e8.tar.gz
ponysay-1f409609b57dd86693371a4bedfe3a1e8ebba3e8.tar.bz2
ponysay-1f409609b57dd86693371a4bedfe3a1e8ebba3e8.zip
m
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index c03cf67..ddb7212 100755
--- a/setup.py
+++ b/setup.py
@@ -172,10 +172,10 @@ class Setup():
conf[key] = prefix + conf[key][4:]
if opts['--opt'] is not None:
- if opts['--bin-dir'] is None: opts['--bin-dir'] = ['/opt/ponysay/bin']
- if opts['--lib-dir'] is None: opts['--lib-dir'] = ['/opt/ponysay/lib']
- if opts['--share-dir'] is None: opts['--share-dir'] = ['/opt/ponysay/share']
- if opts['--cache-dir'] is None: opts['--cache-dir'] = ['/var/opt/ponysay/cache']
+ if opts['--bin-dir'] is None: opts['--bin-dir'] = ['/opt/ponysay/bin']
+ if opts['--lib-dir'] is None: opts['--lib-dir'] = ['/opt/ponysay/lib']
+ if opts['--share-dir'] is None: opts['--share-dir'] = ['/opt/ponysay/share']
+ if conf['shared-cache'] is None: opts['shared-cache'] = ['/var/opt/ponysay/cache']
for dir in ('bin', 'lib', 'share'):
if opts['--' + dir + '-dir'] is not None: