aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2012-08-26 17:34:21 +0200
committerMattias Andrée <maandree@operamail.com>2012-08-26 17:34:21 +0200
commit1b8a80a81c4a91745a350b3621be108d93dddb20 (patch)
tree9a0f5dfe2a50df34997d16d55bd3900629b38dca /setup.py
parent76100d0c57e8e503fcf15a46345ee91c311af364 (diff)
downloadponysay-1b8a80a81c4a91745a350b3621be108d93dddb20.tar.gz
ponysay-1b8a80a81c4a91745a350b3621be108d93dddb20.tar.bz2
ponysay-1b8a80a81c4a91745a350b3621be108d93dddb20.zip
do not allow duplicate configure options
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index d38321c..1e41f72 100755
--- a/setup.py
+++ b/setup.py
@@ -837,8 +837,10 @@ class ArgParser():
(opt, arg, i) = (optqueue[i], argqueue[i], i + 1)
opt = self.optmap[opt][0]
if (opt not in self.opts) or (self.opts[opt] is None):
- self.opts[opt] = []
- self.opts[opt].append(arg)
+ self.opts[opt] = [arg]
+ else:
+ sys.stderr.write('%s: fatal: duplicate option %s\n' % (self.__program, arg))
+ exit(-1)
'''
Prints a colourful help message