aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorjaseg <s@jaseg.de>2013-07-29 18:51:18 +0200
committerjaseg <s@jaseg.de>2013-07-29 18:51:18 +0200
commita79ab969533320582482856758394e74739b152e (patch)
tree59e320c15a282cb57318683815c8e3d529e2f087 /setup.py
parent62e62f1eace5899d0176ef0dd1b66c6ef72f7ab0 (diff)
downloadpixelterm-a79ab969533320582482856758394e74739b152e.tar.gz
pixelterm-a79ab969533320582482856758394e74739b152e.tar.bz2
pixelterm-a79ab969533320582482856758394e74739b152e.zip
Made a proper python package out of this.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py50
1 files changed, 50 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..983d45a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,50 @@
+#!/usr/bin/env python3
+from setuptools import setup
+
+import os, os.path
+import sys
+
+ver = "1.0"
+
+def read(filename):
+ return open(os.path.join(os.path.dirname(__file__), filename)).read()
+
+
+
+if sys.version_info < (3,0):
+ print('Oops, only python >= 3.0 supported!')
+ sys.exit()
+
+setup(name = 'pixelterm',
+ version = ver,
+ description = 'Render pixely images on your terminal. Now also with animated GIF support.',
+ license = 'BSD',
+ author = 'jaseg',
+ author_email = 'pixelterm@jaseg.net',
+ url = 'https://github.com/jaseg/pixelterm',
+ py_modules = ['pixelterm', 'unpixelterm'],
+ scripts = ['pixelterm',
+ 'unpixelterm',
+ 'colorcube',
+ 'gifterm',
+ 'resolvecolor',
+ 'pngmeta'],
+ zip_safe = True,
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: Information Technology',
+ 'Intended Audience :: Intended Audience :: End Users/Desktop',
+ 'License :: Freely Distributable',
+ 'License :: OSI Approved :: BSD License',
+ 'Programming Language :: Python :: 3',
+ 'Topic :: Internet',
+ 'Topic :: Graphics',
+ 'Topic :: System :: Networking'
+ 'Topic :: Text Processing :: Filters',
+ 'Topic :: Utilities',
+ ],
+
+ long_description = read('README.md'),
+ dependency_links = [],
+)