summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorjaseg <git@jaseg.de>2024-04-20 18:18:20 +0200
committerjaseg <git@jaseg.de>2024-04-20 18:18:20 +0200
commit66da7861f368255a2db5be0b6c1c532385687851 (patch)
treec99bb7c026e1504f379ae9f18b8aea5a8a29aa56 /pyproject.toml
parent065db66e958d3d221c0a8d52cf3015caa58a45c3 (diff)
downloadtaep-66da7861f368255a2db5be0b6c1c532385687851.tar.gz
taep-66da7861f368255a2db5be0b6c1c532385687851.tar.bz2
taep-66da7861f368255a2db5be0b6c1c532385687851.zip
Tidy up repo, add README
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..f71352a
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,40 @@
+[build-system]
+requires = ["setuptools"]
+build-backend = "setuptools.build_meta"
+
+[tool.setuptools]
+py-modules = ['bruder']
+
+[project]
+name = "bruder"
+version = "v1.0.0-rc1"
+description = "Print pictures as collages using label tape printers"
+readme = "README.rst"
+authors = [{name = "jaseg", email = "code@jaseg.de"}]
+license = {text = "GPLv2+ or LGPLv2.1+"}
+requires-python = ">=3.10"
+keywords = ['graphics', 'svg', 'printing', 'printer', 'label', 'label printer', 'brother', 'p-touch', 'dithering',
+ 'image processing', 'collage']
+dependencies = ['click', 'beautifulsoup4']
+classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: End Users/Desktop',
+ 'License :: OSI Approved :: BSD License',
+ 'Natural Language :: English',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
+ 'Programming Language :: Python :: 3.12',
+ 'Topic :: Multimedia :: Graphics :: Editors :: Vector-Based',
+ 'Topic :: Multimedia :: Graphics :: Presentation',
+ 'Topic :: Printing',
+ 'Topic :: Scientific/Engineering :: Image Processing',
+ 'Topic :: System :: Hardware :: Universal Serial Bus (USB) :: Printer',
+ 'Topic :: Utilities',
+]
+
+[project.urls]
+homepage = "https://github.com/jaseg/bruder"
+