summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorjaseg <git@jaseg.net>2018-11-08 15:41:46 +0900
committerjaseg <git@jaseg.net>2018-11-08 15:41:46 +0900
commit050d49a56bc54c78c3fc1f4f125b09634d6c5b83 (patch)
tree281cee1a4b07a7cc1da1a0c1406877d9707e4df6 /src/CMakeLists.txt
parent8ee5f4ce6a70e742156c28565fb13ee96ae35a1f (diff)
downloadsecure-hid-050d49a56bc54c78c3fc1f4f125b09634d6c5b83.tar.gz
secure-hid-050d49a56bc54c78c3fc1f4f125b09634d6c5b83.tar.bz2
secure-hid-050d49a56bc54c78c3fc1f4f125b09634d6c5b83.zip
Noise integration compiles
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 25d8683..cb50069 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -24,16 +24,25 @@ add_library (usbhost
cobs.c
)
+add_subdirectory (crypto)
+
+add_definitions (
+ -DBLAKE2S_USE_VECTOR_MATH=0
+)
+
target_link_libraries (usbhost
+ noise
${LIBOPENCM3_LIB}
)
add_executable (demo
+ rand_stm32.c
demo.c
)
target_link_libraries (demo
usbhost
+ noise
)
add_custom_command (TARGET demo