summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjaseg <git@jaseg.net>2018-11-05 10:02:51 +0900
committerjaseg <git@jaseg.net>2018-11-05 10:02:51 +0900
commit5b4c295d009d91347fefa5d48646cf77e5a5f43d (patch)
treeadac4ec964a61b746ad7a70fe738eeffd89ff420 /CMakeLists.txt
parent7c8490211b4f5e681881023a4bf132346bbcd0f2 (diff)
downloadsecure-hid-5b4c295d009d91347fefa5d48646cf77e5a5f43d.tar.gz
secure-hid-5b4c295d009d91347fefa5d48646cf77e5a5f43d.tar.bz2
secure-hid-5b4c295d009d91347fefa5d48646cf77e5a5f43d.zip
Some UART logging work
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b97355d..7b28316 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,10 @@ project (libusbhost C)
set (USE_STM32F4_FS TRUE CACHE BOOL "Use USB full speed (FS) host periphery")
set (USE_STM32F4_HS TRUE CACHE BOOL "Use USB high speed (HS) host periphery")
-set (USE_USART_DEBUG TRUE CACHE BOOL "Use debug uart output")
+set (USE_USART_DEBUG TRUE CACHE BOOL "Enable human-readable serial debug output")
+set (DEBUG_USART USART1 CACHE STRING "USART to use for debug output")
+set (DEBUG_USART_DMA DMA2 CACHE STRING "DMA controller to use for debug usart")
+set (DEBUG_USART_DMA_STREAM_NUM 7 CACHE STRING "DMA stream number to use for debug usart. This must be the stream mapped to the [DEBUG_USART]_TX channel")
# Set compiler and linker flags