summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLouis-Philippe VĂ©ronneau <pollo@debian.org>2022-11-27 16:11:22 -0500
committerLouis-Philippe VĂ©ronneau <pollo@debian.org>2022-11-27 16:11:22 -0500
commit5fbdccc89f60c9e3c2967a1966fac57f6566fa54 (patch)
tree6a2541ddba087a8ff7bc30852e4056915b58b9fc /setup.py
parent30d5ca1f0255184b500cbb43d9b3556a70038c53 (diff)
downloadpython-mpv-5fbdccc89f60c9e3c2967a1966fac57f6566fa54.tar.gz
python-mpv-5fbdccc89f60c9e3c2967a1966fac57f6566fa54.tar.bz2
python-mpv-5fbdccc89f60c9e3c2967a1966fac57f6566fa54.zip
Migrate away from setup.py and use PEP 612-style pyproject.toml
Closes #240.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py40
1 files changed, 0 insertions, 40 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100755
index eface0a..0000000
--- a/setup.py
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/usr/bin/env python3
-
-from setuptools import setup
-from pathlib import Path
-
-setup(
- name = 'python-mpv',
- version = '1.0.1',
- py_modules = ['mpv'],
- description = 'A python interface to the mpv media player',
- long_description = (Path(__file__).parent / 'README.rst').read_text(),
- long_description_content_type = 'text/x-rst',
- url = 'https://github.com/jaseg/python-mpv',
- author = 'jaseg',
- author_email = 'github@jaseg.net',
- license = 'GPLv2+',
- extras_require = {
- 'screenshot_raw': ['Pillow']
- },
- tests_require = ['xvfbwrapper'],
- test_suite = 'tests',
- keywords = ['mpv', 'library', 'video', 'audio', 'player', 'display',
- 'multimedia'],
- python_requires='>=3.7',
- classifiers = [
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: X11 Applications',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)',
- 'License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)',
- 'Natural Language :: English',
- 'Operating System :: POSIX',
- 'Programming Language :: C',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: Python :: 3.9',
- 'Programming Language :: Python :: 3.10',
- 'Topic :: Multimedia :: Sound/Audio :: Players',
- 'Topic :: Multimedia :: Video :: Display']
-)