aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7dbd4bc..e4ca5e5 100755
--- a/setup.py
+++ b/setup.py
@@ -250,6 +250,9 @@ class Setup():
data = data.replace('#!/usr/bin/env python', '#!/usr/bin/env ' + env)
for sharedir in [item[0] for item in sharedirs]:
data = data.replace('/usr/share/ponysay/' + sharedir, conf[sharedir])
+ for sharefile in sharefiles:
+ data = data.replace('/usr/share/ponysay/' + sharefile[1], conf[sharefile[0]])
+ data.replace('\nVERSION = \'dev\'', '\nVERSION = \'%s\'' % (VERSION))
fileout.write(data)
finally: