summaryrefslogtreecommitdiff
path: root/autotools/Makefile.am
diff options
context:
space:
mode:
authorDaniel Santos <daniel.santos@pobox.com>2021-10-11 23:58:22 -0500
committerjaseg <git@jaseg.net>2021-10-14 23:11:20 +0200
commit8173ed8cb62f22ca2ebb33a63b5b9954afb20d7e (patch)
tree4263ebd97466328b6ced984153c3b42036060203 /autotools/Makefile.am
parent1d52554cb1023bed428d71bb3b051d2fbab4327c (diff)
downloadlolcat-8173ed8cb62f22ca2ebb33a63b5b9954afb20d7e.tar.gz
lolcat-8173ed8cb62f22ca2ebb33a63b5b9954afb20d7e.tar.bz2
lolcat-8173ed8cb62f22ca2ebb33a63b5b9954afb20d7e.zip
build: Add autotools option for those who want it
Closes #40.
Diffstat (limited to 'autotools/Makefile.am')
-rw-r--r--autotools/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/autotools/Makefile.am b/autotools/Makefile.am
new file mode 100644
index 0000000..002d475
--- /dev/null
+++ b/autotools/Makefile.am
@@ -0,0 +1,7 @@
+bin_PROGRAMS = lolcat censor
+lolcat_SOURCES = ../lolcat.c
+censor_SOURCES = ../censor.c
+
+LIBS += -lm
+CFLAGS ?= -O3
+AM_CFLAGS = -std=c11 -Wall -Wextra -Wno-sign-compare -Werror=implicit