diff options
author | Paulo Henrique Silva <ph.silva@gmail.com> | 2014-10-26 20:55:22 -0200 |
---|---|---|
committer | Paulo Henrique Silva <ph.silva@gmail.com> | 2014-10-26 20:55:22 -0200 |
commit | d5c8d896d87e02d32d0c0758a09f051c141006f6 (patch) | |
tree | 50e2788e5dfc63db909a3613fff6934a0e80b153 /setup.py | |
parent | d0eedf3dd7ee4fbf19f51de319e48dd964b93561 (diff) | |
parent | 4f076d7b769b0f488888d268a9a199b7545afdd7 (diff) | |
download | gerbonara-d5c8d896d87e02d32d0c0758a09f051c141006f6.tar.gz gerbonara-d5c8d896d87e02d32d0c0758a09f051c141006f6.tar.bz2 gerbonara-d5c8d896d87e02d32d0c0758a09f051c141006f6.zip |
Merge pull request #4 from hamiltonkibbe/master
Many fixes in parsing, rendering and new features
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 66 |
1 files changed, 52 insertions, 14 deletions
@@ -1,23 +1,61 @@ +#!/usr/bin/env python +# -*- coding: utf-8 -*- + +# Copyright 2013-2014 Paulo Henrique Silva <ph.silva@gmail.com> + +# Licensed under the Apache License, Version 2.0 (the "License"); +# you may not use this file except in compliance with the License. +# You may obtain a copy of the License at + +# http://www.apache.org/licenses/LICENSE-2.0 + +# Unless required by applicable law or agreed to in writing, software +# distributed under the License is distributed on an "AS IS" BASIS, +# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. +# See the License for the specific language governing permissions and +# limitations under the License. import os -from setuptools import setup def read(fname): return open(os.path.join(os.path.dirname(__file__), fname)).read() -setup( - name = "gerber-tools", - version = "0.1", - author = "Paulo Henrique Silva", - author_email = "ph.silva@gmail.com", - description = ("Utilities to handle Gerber (RS-274X) files."), - license = "Apache", - keywords = "gerber tools", - url = "http://github.com/curtacircuitos/gerber-tools", - packages=['gerber'], - long_description=read('README.md'), - classifiers=[ + +METADATA = { + 'name': 'gerber-tools', + 'version': 0.1, + 'author': 'Paulo Henrique Silva <ph.silva@gmail.com>, Hamilton Kibbe <ham@hamiltonkib.be>', + 'author_email': "ph.silva@gmail.com, ham@hamiltonkib.be", + 'description': ("Utilities to handle Gerber (RS-274X) files."), + 'license': "Apache", + 'keywords': "gerber tools", + 'url': "http://github.com/curtacircuitos/gerber-tools", + 'packages': ['gerber'], + 'long_description': read('README.md'), + 'classifiers':[ "Development Status :: 3 - Alpha", "Topic :: Utilities", "License :: OSI Approved :: Apple Public Source License", ], -) +} + +SETUPTOOLS_METADATA = { + 'install_requires': ['svgwrite'], +} + + +def install(): + """ Install using setuptools, fallback to distutils + """ + try: + from setuptools import setup + METADATA.update(SETUPTOOLS_METADATA) + setup(**METADATA) + except ImportError: + from sys import stderr + stderr.write('Could not import setuptools, using distutils') + stderr.write('NOTE: You will need to install dependencies manualy') + from distutils.core import setup + setup(**METADATA) + +if __name__ == '__main__': + install()
\ No newline at end of file |