summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorjaseg <git@jaseg.de>2022-06-10 22:23:28 +0200
committerjaseg <git@jaseg.de>2022-06-10 22:23:28 +0200
commit89f3aeeac77d6b608a38d025ccab666261690933 (patch)
tree70e9e59345c0deea9854a66c6a473245e8922d05 /setup.py
parentb1be792c5200b6af58773486ac060e247e8c2514 (diff)
downloadgerbonara-89f3aeeac77d6b608a38d025ccab666261690933.tar.gz
gerbonara-89f3aeeac77d6b608a38d025ccab666261690933.tar.bz2
gerbonara-89f3aeeac77d6b608a38d025ccab666261690933.zip
Gitlab CI testv0.10.1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index c32f65a..b6e2172 100644
--- a/setup.py
+++ b/setup.py
@@ -5,9 +5,13 @@ from setuptools import setup, find_packages
import subprocess
def version():
- res = subprocess.run(['git', 'describe', '--tags', '--match', 'v*'], capture_output=True, check=True, text=True)
- version, _, _rest = res.stdout.strip()[1:].partition('-')
- return version
+ try:
+ res = subprocess.run(['git', 'describe', '--tags', '--match', 'v*'], capture_output=True, check=True, text=True)
+ version, _, _rest = res.stdout.strip()[1:].partition('-')
+ return version
+ except:
+ subprocess.run(['git', 'describe', '--tags', '--match', 'v*'])
+ raise
setup(
name='gerbonara',