summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHamilton Kibbe <hamilton.kibbe@gmail.com>2014-10-26 17:20:47 -0400
committerHamilton Kibbe <hamilton.kibbe@gmail.com>2014-10-26 17:20:47 -0400
commit254f3e51845de5679f11934a807e8f0f7d1f5713 (patch)
treeecff7bbb330b99472c5544140b3463250dd4052e /setup.py
parent18e3b87625ddb739faeddffcaed48e12db6c7e8b (diff)
parentd0eedf3dd7ee4fbf19f51de319e48dd964b93561 (diff)
downloadgerbonara-254f3e51845de5679f11934a807e8f0f7d1f5713.tar.gz
gerbonara-254f3e51845de5679f11934a807e8f0f7d1f5713.tar.bz2
gerbonara-254f3e51845de5679f11934a807e8f0f7d1f5713.zip
Merge changes from upstream
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py61
1 files changed, 61 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..02b9df6
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,61 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+# Copyright 2013-2014 Paulo Henrique Silva <ph.silva@gmail.com>
+
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+
+# http://www.apache.org/licenses/LICENSE-2.0
+
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+import os
+
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+
+METADATA = {
+ 'name': 'gerber-tools',
+ 'version': 0.1,
+ 'author': 'Paulo Henrique Silva <ph.silva@gmail.com>, Hamilton Kibbe <ham@hamiltonkib.be>',
+ 'author_email': "ph.silva@gmail.com, ham@hamiltonkib.be",
+ 'description': ("Utilities to handle Gerber (RS-274X) files."),
+ 'license': "Apache",
+ 'keywords': "gerber tools",
+ 'url': "http://github.com/curtacircuitos/gerber-tools",
+ 'packages': ['gerber'],
+ 'long_description': read('README.md'),
+ 'classifiers':[
+ "Development Status :: 3 - Alpha",
+ "Topic :: Utilities",
+ "License :: OSI Approved :: Apple Public Source License",
+ ],
+}
+
+SETUPTOOLS_METADATA = {
+ 'install_requires': ['svgwrite'],
+}
+
+
+def install():
+ """ Install using setuptools, fallback to distutils
+ """
+ try:
+ from setuptools import setup
+ METADATA.update(SETUPTOOLS_METADATA)
+ setup(**METADATA)
+ except ImportError:
+ from sys import stderr
+ stderr.write('Could not import setuptools, using distutils')
+ stderr.write('NOTE: You will need to install dependencies manualy')
+ from distutils.core import setup
+ setup(**METADATA)
+
+if __name__ == '__main__':
+ install() \ No newline at end of file