diff options
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -1,14 +1,21 @@ #!/usr/bin/env python3 -from setuptools import setup, find_packages +from setuptools import setup + +def readme(): + with open('README.rst') as f: + return f.read() + setup( name = 'gerbolyze', - version = '0.1.0', + version = '0.1.6', py_modules = ['gerbolyze'], scripts = ['gerbolyze'], description = ('A high-resolution image-to-PCB converter. Gerbolyze reads and vectorizes black-and-white raster ' 'images, then plots the vectorized image into an existing gerber file while avoiding existing features such as ' 'text or holes.'), + long_description=readme(), + long_description_content_type='text/x-rst', url = 'https://github.com/jaseg/gerbolyze', author = 'jaseg', author_email = 'github@jaseg.net', |