aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index d1998a4..e548f2e 100755
--- a/setup.py
+++ b/setup.py
@@ -10,8 +10,11 @@ from pathlib import Path
import re
def get_tag():
- res = subprocess.run(['git', 'describe', '--tags', '--match', 'v*'], capture_output=True, check=True, text=True)
- return res.stdout.strip()
+ try:
+ res = subprocess.run(['git', '--git-dir', str(Path(__file__).with_name('.git')), 'describe', '--tags', '--match', 'v*'], capture_output=True, check=True, text=True)
+ return res.stdout.strip()
+ except subprocess.CalledProcessError as e:
+ return 'v0.0.0-dev'
def get_version():
version, _, _rest = get_tag()[1:].partition('-')