aboutsummaryrefslogtreecommitdiff
path: root/svg-flatten/setup.py
diff options
context:
space:
mode:
authorjaseg <git@jaseg.de>2021-09-26 15:45:09 +0200
committerjaseg <git@jaseg.de>2021-09-29 16:38:13 +0200
commit8a64621e8c8610a45884df82b46859bc3297d3e3 (patch)
tree4b6265bb01377e16e66dddeee8259f40ea86d562 /svg-flatten/setup.py
parent7eb0b9d7e42a20b85bd7afbfe3d33d9dd5fa5794 (diff)
downloadgerbolyze-8a64621e8c8610a45884df82b46859bc3297d3e3.tar.gz
gerbolyze-8a64621e8c8610a45884df82b46859bc3297d3e3.tar.bz2
gerbolyze-8a64621e8c8610a45884df82b46859bc3297d3e3.zip
CI/svg-flatten: add wasm builds
Diffstat (limited to 'svg-flatten/setup.py')
-rw-r--r--svg-flatten/setup.py48
1 files changed, 48 insertions, 0 deletions
diff --git a/svg-flatten/setup.py b/svg-flatten/setup.py
new file mode 100644
index 0000000..9c88ea2
--- /dev/null
+++ b/svg-flatten/setup.py
@@ -0,0 +1,48 @@
+import subprocess
+from setuptools import setup, find_packages
+from pathlib import Path
+import re
+import shutil
+
+def version():
+ res = subprocess.run(['git', 'describe', '--tags', '--match', 'v*'], capture_output=True, check=True, text=True)
+ version, _, _rest = res.stdout.strip()[1:].rpartition('-')
+
+def long_description():
+ with open("README.rst") as f:
+ return f.read()
+
+setup(
+ name="svg-flatten-wasi",
+ version=version(),
+ author="jaseg",
+ author_email="pypi@jaseg.de",
+ description="svg-flatten SVG downconverter",
+ long_description=long_description(),
+ long_description_content_type="text/x-rst",
+ license="AGPLv3+",
+ python_requires="~=3.7",
+ setup_requires=["wheel"],
+ install_requires=[
+ "importlib_resources; python_version<'3.9'",
+ "appdirs~=1.4",
+ "wasmtime>=0.28",
+ "click >= 4.0"
+ ],
+ packages=["svg_flatten_wasi"],
+ package_data={"svg_flatten_wasi": [
+ "*.wasm",
+ ]},
+ entry_points={
+ "console_scripts": [
+ "wasi-svg-flatten = svg_flatten_wasi:run_svg_flatten",
+ ],
+ },
+ project_urls={
+ "Source Code": "https://git.jaseg.de/gerbolyze",
+ "Bug Tracker": "https://github.com/jaseg/gerbolyze/issues",
+ },
+ classifiers=[
+ "License :: OSI Approved :: GNU Affero General Public License v3 or later (AGPLv3+)",
+ ],
+)