diff options
author | jaseg <git@jaseg.de> | 2024-05-23 10:34:43 +0200 |
---|---|---|
committer | jaseg <git@jaseg.de> | 2025-01-22 14:45:13 +0100 |
commit | 05d4b0195f7a4a05d955ff221e07ff58624e4b54 (patch) | |
tree | 0b696a9ddd851b1a03da7747ddc6affa8b5b0460 /setup.py | |
parent | 39feccb9797af835e5b5acd837e9a7cb1af4504e (diff) | |
download | gerbolyze-05d4b0195f7a4a05d955ff221e07ff58624e4b54.tar.gz gerbolyze-05d4b0195f7a4a05d955ff221e07ff58624e4b54.tar.bz2 gerbolyze-05d4b0195f7a4a05d955ff221e07ff58624e4b54.zip |
Make tox tests run
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 7 |
1 files changed, 5 insertions, 2 deletions
@@ -10,8 +10,11 @@ from pathlib import Path import re def get_tag(): - res = subprocess.run(['git', 'describe', '--tags', '--match', 'v*'], capture_output=True, check=True, text=True) - return res.stdout.strip() + try: + res = subprocess.run(['git', '--git-dir', str(Path(__file__).with_name('.git')), 'describe', '--tags', '--match', 'v*'], capture_output=True, check=True, text=True) + return res.stdout.strip() + except subprocess.CalledProcessError as e: + return 'v0.0.0-dev' def get_version(): version, _, _rest = get_tag()[1:].partition('-') |